This is the bare minimum configuration to make Orange PartnerNet fiber connection work on Mikrotik on LAN1 port:
/interface bridge
add name=bridge1
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=****** use-peer-dns=yes user=*****@orangenet.sk
/ip pool
add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.254
/interface bridge port
add bridge=bridge1 interface=ether2
/ip address
add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridge1 name=dhcp1
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1
/ipv6 address
add from-pool=OrangeSK interface=bridge1
/ipv6 dhcp-client
add interface=pppoe-out1 pool-name=OrangeSK request=prefix
It should connect to IPv6, while omitting IPv4:
/interface pppoe-client monitor 0
;;; Telekom-Orange
status: connected
uptime: 3m16s
active-links: 1
encoding:
service-name:
ac-name: N-101-BA-BNG-10
ac-mac: 6C:6C:D3:xx:xx:xx
mtu: 1492
mru: 1492
local-address: 0.0.0.0
remote-address: 0.0.0.0
local-ipv6-address: fe80::e9b5:d3db:0:c
remote-ipv6-address: fe80::6e6c:d3ff:fe5e:111
Unfortunately though, Mikrotik with this config just by itself won't support accessing IPv4 servers by any means, as this is IPv6-only PPPoE connection. Orange uses CGN server to access IPv4 via their Zyxel VMG3927 device.
For this setup to work flawlessly for IPv6 and IPv4 too, one needs to add their IPv6 to IPv4 translation mechanism. The most straightforward way is to use Tailscale on a VPN which has both IPv4 and IPv6 access.
I am so far sticking to use Zyxel output as an input to my Mikrotik configured as a WAN port. Will post an update if I find surefire way to ditch the Zyxel while keeping simple access to IPv4. Enjoy!